LoRaWAN Library doesn´t work

I’ve tried to use the LoRaWAN library that Heltec provides but I had some problems with it.

  • First, the guide is not updated. When you install the library, it doesn´t appear the option of choosing the Region in the Arduino tools menu. I think I resolve that changing this line of code:

/LoraWan region, select in arduino IDE tools/
LoRaMacRegion_t loraWanRegion = LORAMAC_REGION_EU868;

  • Second, once that you compile and upload the program, as soon an it tries to do the join, it reboots. I obtain this message:
ESP32 MCU init...
ESP32 MCU inited OK!

LoRaWAN EU868 Class C start!

joining...
Guru Meditation Error: Core  1 panic'ed (StoreProhibited). Exception was unhandled.
Core 1 register dump:
PC      : 0x400d46d3  PS      : 0x00060330  A0      : 0x800d4466  A1      : 0x3ffb1ef0  
A2      : 0x3ffb1f24  A3      : 0x3ffb1f1c  A4      : 0x00000031  A5      : 0x00000000  
A6      : 0x3ffb8f22  A7      : 0x00000006  A8      : 0x00000000  A9      : 0x00000001  
A10     : 0x00000000  A11     : 0x3ffc1d88  A12     : 0x3ffc02fc  A13     : 0x00000000  
A14     : 0x00ff0000  A15     : 0xff000000  SAR     : 0x0000001b  EXCCAUSE: 0x0000001d  
EXCVADDR: 0x00000000  LBEG    : 0x400014fd  LEND    : 0x4000150d  LCOUNT  : 0xffffffff  

Backtrace: 0x400d46d3:0x3ffb1ef0 0x400d4463:0x3ffb1f10 0x400d6dd3:0x3ffb1f50 0x400d11db:0x3ffb1f90 0x400d9b39:0x3ffb1fb0 0x40088f4d:0x3ffb1fd0

Rebooting...
  • Third, everytime I compile the program I obtain this message that doesn´t stop the upload of the code, but I think that something is wrong:

Invalid version ‘Internal RTC2.0’ for library in: C:\Users\Dani\Documents\Arduino\libraries\ESP32_LoRaWAN-master

I am trying this with a Heltec WiFi LoRa 32 (V2), a RG1xx Laird Gateway and Chirpstack.

Can anyone help me? Thank you.

Maybe you need to download and update the latest LoRaWAN support environment from this. https://github.com/Heltec-Aaron-Lee/WiFi_Kit_series.git

I already have the latest LoRaWAN support enviroment, so it is not the problem.

Double click get.exe to install it?

1 Like

I did it using the Arduino IDE, I tried downloading the repository as you have shown, and now it works, the program doesn´t crash anymore. I still have the third problem but I suppose that it doesn´t affect to the program.

Thank you very much :slight_smile:

Works for me too. In my case there was 2 boards with the same name.

forum

Thanks.

You need to delete the old library.