Heltec WiFi LoRa 32 (V3) Sketches & OLED not working

I wasn’t sure if this should be a new post but, it is related to a sketch not working (like here) on my new Heltec WiFi Lora 32 (V3). I did order the V2 but got the V3 instead.

OS: Windows 10
IDE: Arduino IDE
Board: Heltec WiFi LoRa 32 (V3)
Installed latest software as referred in the topic: community_heltec_cn/t/wifi-lora-32-v3-w-esp32-s3/11944/5?u=gritty

I followed this thread and a couple of others on V3 (not much out there yet). I tried two different sketches.

  1. The Demo Sketch that comes with Heltec called WiFi_LoRa_32FactoryTest.ino but I had to modify the ino file and took code from the main.cpp file here because the default came with heltech.h header which runs into compiling errors:
  2. The Demo Sketch that comes with Heltec called SimpleDemo.ino in Arduino IDE - no modifications made here.

In both sketches, I go through the verify/compile and then do an upload to the board (Port: COM6 and Library: heltec_0.0.7).

In either case, nothing really happens/shows on the board. The OLED doesn’t light up when running the SimpleDemo.ino sketch and there is no Blink on the LED when running the first sketch.

To summarise:

  • When I first connect my board via USB, there is a light (orange) but that’s it.
  • When I successfully upload any (successfully compiled) sketch, nothing happens - it is in the same state as above with the orange light.

The worse thing is I don’t get any errors when compiling and when uploading (giving me a success on both counts), saying it is a success on both sketches.

Any help appreciated, cheers!

You’re using the wrong software. Whether that’s because the right stuff isn’t installed or you’ve just selected the wrong board isn’t obvious.

First up, anything that includes the heltec.h header file will not work with a V3 board. If you end up with an example that includes the heltec.h, it’s usually because you’ve chosen the wrong board.

Second, you must choose the correct FactoryTest sketch—there’s a different one for almost every board, and you need the one for your board, in this case WiFi_LoRa_32_V3_FactoryTest.ino—you’ve got to have the V3 version. Remember, the V3 boards use a completely new processor and a completely new LoRa Node chip compared to previous versions, so the V3 boards require completely new support software.

With all that in place, you will then most likely need to modify anything but trivial sketches that ran on earlier versions of the boards to use the new support software, and then, logically enough, those sketches will no longer be compatible with the old versions of the board in question.

And if it hasn’t been fixed yet, you will have to explicitly define the on-board OLED to be on pin 35.

Once again I’ll say that Heltec would have done us all a really big favour if they’d given the V3 boards completely new designators, to make it obvious that, while their appearance and functionality may be similar to earlier versions, they are completely new boards.

The board I’ve chosen on the Arduino IDE is WiFi LoRa 32(V3)/Wireless shell(V3)/Wireless stick lite (V3)

I got this straight from the Board Manager looking up for Heltec Boards and got the Heltec ESP32 Series Dev-boards v0.0.7

I managed to find the V3 example Factory Test sketch under: File>>Examples>>Heltec-Example>>Factory_Test>>WiFi_LoRa_32_V3_FactoryTest.ino

I compiled that successfully and uploaded successfully via PORT:COM6.

Also got a new ALOGIC USB-A to USB-C cable straight into the Heltec module.

I also explicitly hardcoded the GPIO to 35 on lines 309, 310 and 365, respectively:

  • pinMode(35,OUTPUT)
  • digitalWrite(35, LOW)
  • digitalWrite(35, HIGH)

But still no joy. I get the same result as mentioned previously.

Well, that description of your software environment now reads as it should, so I’m pretty much out of ideas on the Heltec side of things.

So I guess the only other reason I can think of is, I was sent a disfunctional V3 module.

Well, there has been the odd comment on this forum about ports on host computers, and you probably also need to be sure that your USB cable is not just new, but has all the relevant ‘bits’, also per comments in other threads, to function. To rule out these options, and also the possibility that there’s something else not quite right with your IDE installation, it would be handy to some other, ideally similar, processor that worked in your environment.

First Select Tool --> Board —> Heltec ESP32 Series Dev Board --> Select “Wifi LoRa 32 (V3)”

Select Examples --> Heltec Example --> Factory_Test --> select Wifi_LoRa_32_V3_FactoryTest


Followed @yilberrojas advice. But as per the prior post I made with @UniquePete, this is the initial and final state of the device when running the Factory_Test script for V3. Nothing really happens between these states.

  1. press the reset button

  2. if the problem persists you should add:
    void setup(){

Did a press of the RST button but nothing happened.

I uploaded V3 factory test sketch with Mcu.begin(); - nothing happened again.

Same as the first picture above.

Could it be related to the USB power connected to my Heltec?


I also used USBDeview to check the COM8 port and it gave me this:


Power: 100mA
USB Version: 1.10

Open the serial port and check the output.

#include “Arduino.h”
//#include “WiFi.h”

#include “LoRaWan_APP.h”
#include <Wire.h>
#include “HT_SSD1306Wire.h”

SSD1306Wire factory_display(0x3c, 500000, SDA_OLED, SCL_OLED, GEOMETRY_128_64, RST_OLED);

void setup() {
factory_display.init(); //
factory_display.flipScreenVertically(); //
factory_display.setFont(ArialMT_Plain_16); //
factory_display.drawString(0, 0, “Heltec!”); //
factory_display.display(); // Muestra el contenido de la pantalla OLED

void loop() {
// Nada más que hacer en el bucle principal

try this code

Verify and Upload were successful but nothing happened

Still same as before.

It must be the board, because it should work. I have one with that version and it works perfectly

what were your hardware specs i.e. linux/win11/win10, etc. ?

I got the board on Heltec’s AliExpress site. Do you know if they do replacements?

Arduino IDE 2.0.4 and win10

i bought it on amazon

I have the same problem, I bought the V3 board and it doesn’t compile, the only way was to change the “if” in “heltec.ccp” where “wifi_lora_32_V2” to “wifi_lora_32_V3” then the display worked but LoRa32 doesn’t work and wifi doesn’t work either