Heltec LoRa ESP32 JSON Board Install Fails

Trying to install the board manager for the Heltec LoRa ESP board. Instructions say to add the following to the board manager:

https://resource.heltec.cn/download/package_heltec_esp32_index.json

This fails… I then found a reference in this site to use the following:

http://resource.heltec.cn/download/package_heltec_esp32_index.json

This fails as well. Is the resource server down? Is there some other new location? My boards are useless if I can’t program them…

Using Arduino IDE 1.8.13, Java 15.0.1, Mac OS Catalina 10.15.7

Is there someone out there that can confirm if they have it working on the above? This is completely blocking forward progress on coding! Heltec? Anyone?

hi,

could you try the git version Development environment for our esp32 device?


%E5%9B%BE%E7%89%87

I did and that and get the…

fatal: No url found for submodule path ‘libraries/AzureIoT’ in .gitmodules

…issue and the git install process fails.

hi,

The download of git is generally no problem.

could you check your Web environment.And Read the documentation carefully.

Did that. The git install fails with the error mentioned above.

It would sure be nice if the developers of this software tried installing this on the various OS’ they claim to support. So far both installation processes continue to fail. I have other boards with other board managers and their JSON files all load properly and work as expected. Come on guys…on GIT there are other posting referencing the exact same problem using the GIT install process. Please address the JSON and GIT issues.

JSON files still fail to load…

For those following this issue please refer to the following: