WiFi_LoRa_32_v2 JSON Config Won't Load For Arduino IDE

Trying to install the board manager for the Heltec LoRa ESP board. Instructions say to add the following to the board manager:


This fails… I then found a reference in this site to use the following:


This fails as well. Is the resource server down? Is there some other new location? My boards are useless if I can’t program them…

I’ve also tried to access the JSON file using the http://jsonviewer.stack.hu viewer, and it fails to load there as well. I’ve posted this in the LoRa_Node section but have received no useful help. If you have a resolution please post as the boards are useless for me now.

I also tried to load the board drivers using the GIT process but that fails as well with a “fatal: No url found for submodule path ‘libraries/AzureIoT’ in .gitmodules” error.

I’m using Arduino IDE 1.8.13 on Mac OS X 10.15.6 (Catalina) if that matters…but I’ve also tried the above using Windows 10…


we have updated the link.

Still does not work. Both https and http do not work.

Sir…Are you loading those JSON files from a local directory and not from the web site according to the pic you loaded. It’s not surprising you can access your local files from your local PC. How about trying from the same URL your documentation says we should use?

Also, it’s not just me that is having the problem. If you’re inside you’re firewall at the office maybe it works fine but the outside world can’t access the URL! Have you tried accessing the documented URL from outside your firewalls?

We’re not making this stuff up, so please give the outside access test a shot.

Finally, if you’re sure everything is working and it’s an end user issue can you simply package up the files, zip them, and put them on GIT so we can pull them and install locally?

In addition…if you can’t or won’t address the JSON loading issue can you at least resolve the GIT install process fail where we get a “fatal: No url found for submodule path ‘libraries/AzureIoT’ in .gitmodules” error?

If you fix that path error I can try the GIT process.

Finally, I hope you’re able to address the above issues as a service to your customers. However, I’ve waited to long for a resolution and have simply pointed my IDE to the following JSON file, which of course loads just fine, and hopefully supplies the needed functionality for the boards I have…



Could you delete the files in this path:/Users/(username)/Library/Arduino15

The Library folder is hidden by default, and you can only see it when you display the hidden folder “Shift + Command + .”.

we doubt the problem is the Cache problem.

This happens on several different machine. I’ve moved on and loaded a board manager from a different location, which amazing seems to work just fine. I am very disappointed on your customer service. You seem to think these access issues are all end user issues. I’ll be posting a scathing review on Amazon for you customer support.

Can you please tell us where is your location? Just your country is OK. We will try to set up a VPN in your location and have a try.

We are in the mainland of China with the great firewall. I guess if the great firewall blocked something.

Anyway, you can install the development framework via Git: Installation instructions for Mac OS
Or do you use Teamviewer? We may help you solve the problem via Teamviwer.

I’m now working with my ISP as I suspect they are blocking access to certain domains ending in CN or originating in China.

I have other products I’ve ordered from Alibaba and they are exhibiting similar issues. I’ve tried accessing from my cell phone with WiFi off and I can access them. I’m going to take my laptop out and connect via a different ISP and see how it goes.

And, I’ve changed my review on Amazon…it’s at Five Stars now with an explanation of what has happened.

I have not got confirmation on the blocking yet, but assuming it’s an issue with the ISP, I apologize for the hassle I’ve put you all thru. I will post an update here when/if I get confirmation.


I am having the same issue as the Madmacks.

When I put in the URLs as posted in this post I too am getting the error download message.

I am in France by the way.



Hi! I had same issue today (2021.04.23) with a fresh installation of arduino IDE. The IDE could not download the cubecell and esp32 mainboard definition files from https://resource.heltec.cn/download/ (Error message same than screenshot of madmacks) Btw I downloaded the json files manually (from same url with browser) and put them to the arduino15 (or in case of portable IDE to the portable) directory, and it solved the problem. After restart the error message still looks but the mainboard manager found the packages by searching the “heltec” and “cube” words, and installed them correctly. Maybe this time the issue was in the IDE(?)


Please empty this folder and re-donwload the Development environment.


I think it is a certificate problem. I have done the following, and it has worked for me.
(MacOS 10.14)
cd /Users//Library/Arduino15
wget https://resource.heltec.cn/download/package_heltec_esp32_index.json
Resolving …
Connecting to … connected.
WARNING: cannot verify … certificate, issued by /C=US/O=DigiCert Inc/OU=...digicert.../CN=Encryption Everywhere DV TLS CA - G1': Unable to locally verify the issuer's authority. HTTP request sent, awaiting response... 200 OK Length: 15368 (15K) [application/json] Saving to:package_heltec_esp32_index.json’

100%[=============================================>] 15,368 --.-K/s in 0s

(1.10 GB/s) - `package_heltec_esp32_index.json’ saved [15368/15368]

Then the IDE found it.

Woop thanks Rocko, this worked for me perfectly (I got bigsurred and decided to go back to an older os, then needed to reinstall everythingarrrrrgrghhh!)

Having the same issue. I’m running PC with Windows 10. The path you mentioned doesn’t exist in my PC. Which files exactly should I delete?

Hi again. I found this post:

It has the following link which I have successfully used:

1 Like