Cubecell and DS18B20

Hello,

I cannot get the DS18B20 onewire sensor to work on cubecell devboard and I just can’t understand what I’m doing wrong… I tried all of the onewire examples available in arduino, but cannot get it working…
I get error: No more addresses.
or : then it just gives -127 as reading for the sensor, depending on the example I use.

Can anyone help? would be really happy for any ideas :slight_smile:

/Harri

have you tried the examples in the CubeCell repository?

Yes, have tried also that example and only get:
“Temperature for the device 1 (index 0) is: -127.00”

So I really don’t have ideas what could be wrong… measured voltage on the sensor and that is okay, also tried with 3 different sensors (one of them has been working before with another board).

/Harri

are you using parasite oder external power for the sensor?
have you the resistor in place?

cubecell
Here is a picture of how it is connected, I believe it should be right connected, powered from Vext from the dev board, 4,7kohm resistor between Vdd and data.

Edit:
Tried it on capsulo, same problem…