Compiling SSD1306SimpleDemo.ino no longer works

Hello, I am trying to compile the example SSD1306SimpleDemo.ino on my Mac (Big Sur) but I get the following errors. This used to work before. I downloaded from:

Traceback (most recent call last):
File “”, line 57, in
File “/Library/Python/2.7/site-packages/PyInstaller/loader/”, line 389, in load_module
File “serial/tools/”, line 29, in
File “/Library/Python/2.7/site-packages/PyInstaller/loader/”, line 389, in load_module
File “serial/tools/”, line 31, in
File “/Library/Python/2.7/site-packages/PyInstaller/loader/”, line 389, in load_module
File “serial/tools/”, line 32, in
ValueError: dlsym(RTLD_DEFAULT, kIOMasterPortDefault): symbol not found
Failed to execute script esptool
exit status 255
/Applications/ returned 255
Error compiling for board Heltec WiFi Kit 32.

Many thanks,


How did you download the development environment?

Git version? or board Manager?

Maybe you need to download this extra:

well - like I said: I downloaded the Arduino example from

It worked well on Mac OS 10.15, but after I upgraded to Mac OS 11 (Big Sur) I get these errors when compiling.

The aforementioned link is the one recommended for the OLED Heltec board (

If there is another sample project that I should use with Arduino IDE on Mac OS Big Sur, then please let me know.

Many thanks,


We have found the reason.

As you kown, This project is completely cloned from the ESP32 and ESP8266 projects provided by Espressif.

We tried the original development environment of espressif, but still failed to compile.

The reason is that the python toolchain is not compatible with Mac OS 11.

We have submitted the question to espressif. Now we need to wait for them to update the original development environment.

yes - correct. Many thanks for your support. Waiting for your update.

Any update on the issue? We are now in end of December.
I can not use your board with any example.

For ESP8266 there is a workaround updating the “”. Is there no workaround in your package?

ESP8266 Workaround Big Sur



can you please escalate this issue? I submitted the ticket in November and now it is end of February and I still cannot compile on macOS 11.

Thank you

I encounter this problem aswell and I fix it without rebuilding the esp32 driver.

For your reference: