? Common Failure mode of CubeCell Capsules

Hi Arron

I have had an issue with the ASR6501 CubeCells. I have had a few working in the field with BH1750 Light sensors monitoring light level in Greenhouses all very well. But recently 2 have failed with the same issue.

Failure mode of CUBECELL CAPSULE

The module I have been fitted with 100mhr Lipo Battery and is charged with USB debug Board, normally has a sleep current around 20µA. But now has a current consumption sleeping of 5mA, and now fail in under a day.

I have tested the boards and swapped the RF/MCU over to checked they are ok and they are.

I have two capsules with the same fault, but others working fine in the field. The fault is in the Interface board power supply arrangement / switching. I have tested both boards and have the same issue:

  • They charge ok and get to the correct voltage on the LiPo and then switch off the charging.
  • The units function RF/ MCU correctly. Transmits correct data to TTN.
  • Vext Turn on and off correctly.
  • That if the USB is used to charge the batteries, when they reach full capacity (light off) and still connected, the current is then taken at around 20µA from the battery to power the capsule. If I now remove the USB /debug board, the current taken from the battery then goes to 5mA, in sleep state more when transmitting.

I do not have a proper drawing of the CubeCell capsule power supply area (the below is from 151 board) but looking at components it seems like 151 is similar with some modifications for Vs. Is it connected to the +5V line via a diode?

This is not a sketch issue as all the units have the same sketch and only these two have failed.

Has Q1 failed if so? is this a design flaw with the peak voltage spikes that may occur when the USB is plugged in / out? Or do you have any other views for this failure mode?

Any Software or Hardware Fixes?

I am concerned that more will fail in the field in time, and could this fault also eccet the new CubeCells if they use the same design.


P.S Placed on GITHUB as well.


Is this the same issue that somebody noticed before? Whereby if you reset the CubeCell after disconnecting the USB, the quiescent current drops to where it ought to be?

Thats right you have to press reset after disconnecting usb. If not the usb serial interface will draw power

I found the thread that alerted me to this behaviour(I had the same problem a while back).

have you tried a power cycle after disconnecting usb?
that was the hint in the thread you found.

Sorry, I don’t have a problem, I was just trying to help the OP.

Hi both yes I had tried both power cycling and reset after usb debug removed. Constant current consumption of 4.4-4.5 mA on both units . I looks to me as component failure but wait see if Arron etc reply. Thanks Simon