ASR6502S Original Firmware flashing ***For New Users***

Hello Everybody!

I am starting to test the ASR6502S (cubecell). The first thing I am trying to do is to be able that I can flash the original firmware before start testing it… I am new with Arduino IDE also… I have been reading a lot of information during many days but still I am not able to solve my problems so I am writing you for help. I am sure this issue is a piece of cake for you all…

I installed the Arduino IDE and the entire Heltec framework and I can see all the examples and files (sketchers) but I do not know if the original firmware is in it.

Could you know what file should I select if I want to restore the board to its factory state?

I also downloaded the CubeCell configurator. But I select the port and clikc on connect and get no info… Also If I click on “Read” nothing happens and

Anf If I try in sensors i get “07.03.23 14:41:44: AT+RESET=1”…

I also tryed to check on the flash but got no communciation with the board

Woudl you know What could I do to be sure I am communciating and be able to flash the original factory program in case of any trouble…

I tried to include many pictures but since I am a new user I am limited to only one picture

Thanks in advance,

So I am not sure I am communicating properly

Hello people, continue searching for the solution. I found this video

This guys says he takes another heltec board to factory settings… following he procedure, I should be able to do it loading the file in the Arduino IDE (afer selecting my bouard in this case a ASR6502S at Tools/Board/CubeCell Development Framework/CubeCell GPS (HCC-AB02S)) at
File/Examples/Examples for CubeCell GPS (HCC-AB02S)/Basics/Factory_Test/Factory_Test_AB02S

Could somebody confirm???

Also I got a little confused due to the fact that there is also a Flash “Example Skecth” at File/Examples/Examples for CubeCell GPS (HCC-AB02S)/Basics/Flash/

What would be those flash files for?

Woudl you know id there is any document to read about all those Example files? What do they do?

Thanks in advance!

This is only a few use examples, which can be modified according to your own needs.

Thanks @navi for your kind response. Son where can I find the original Factory fimrware in case I need it?
Thanks in advance,

If you mean bootloader, that part cannot be modified.

I have found this video in Youtube. This guy explains how to load programs using the Arduino IDE

When I tried to load the progrma in the CubeCell I got the " [Unhandled error: Timed out waiting for Bootloader"

That issue was solved thanks to the procedure explanined by @UniquePete in this post Unhandled error: Timed out waiting for Bootloader response

I still do not how to bring the board to its factory firmware state… Any help is well appreciated…

Thans you in advance

I am sorry, in order to avoid the error, the procedure must include the RST button, as explained by @UniquePete and @beef3k in this post

  1. Hold USER
  2. Press RST
  3. Release RST
  4. Program via CubeCellflash.exe -serial “COM3” firmware.cyacd (should also work from Arduino/Platformio, but was attempting to remove those as variables).
  5. Once programming completes, release USER