Unhandled error: Timed out waiting for Bootloader response

You need to release the USER key after plugging usb in and before uploading

1 Like

Oh I see, I did it, but I keep getting the same error… maybe the board isn’t working properly?

Have you connected the usb board in the right direction?
On the usb board and in the capsule is white dot, both must allign

Hello, yes I connected the board in the right direction, still getting this Timed out waiting for Bootloader response. I connected the board only and get the error too. Do you get this error if you connect the board only?

if you only connect the board there is nothing that could answer.
you have to connect the board to the capsule, the board is only a usb to serial converter.

if the USER key method does not work your capsule may be broken.

I have two with the same problem. can all them be broken?

After trying with another cubecell capsule using the same cable and board, this new cubecell worked… so… maybe my other cubecell is broken.

Are your two capsules tested in the same debugger?

The probability of the capsule itself breaking is very low, because the logic control part that enters the bootloader is not in the capsule, but on the debugger. The cause of the problem may be poor contact or oxidation of the pins. Try to use sandpaper to gently remove the oxide layer on the pin header surface may solve this problem.

After checking the microchip I didn’t find any oxidation in the pins, and compared to the others microchips of my capsules that work I didn’t find any special defect.

I change the microchip with other capsule and the capsule work, so this part might be damaged.

Unfortunately I have the same issue as @kordhrufan and @cvale on a CubeCell Dev Board (not a capsule).

Unhandled error: Timed out waiting for Bootloader response

USER button reset isn’t working. Is there an easy way to recover the bootloader (if thats the problem?).

1 Like

WASN, Your method saved me a lot of despair. Many Thanks. Notice to disconnect the battery also, if you have one.

Hello Guys, I encountered same Problem After uploading Air quality Sensor example I was not able to upload anything Else,
Tried User Button, Tried Reset Button both on capsules and on boards but nothing happened.

When I put back Sensor of the last Sketch that I upload and let it start and I Could start reading parameters of sensor from Serial Monitor, After that I was able to upload New Sketch.

Not sure if this somehow helps anyone but that was the case with me

I encountered the same problems as others. I discovered that if I plug the sensor board (in my case CCS811) into the debugging board. Then plug the debugging board into CubeCell Capsule. The firmware upload works fine. However, if I remove the sensor board, then the upload failed with same error message as others have described.

I am using a Cube cell AB02 but I experienced an issue when compiling any sketch: Initialising bootloader.
[8120] Failed to execute script CubeCellflash
I tried to follow your suggestion (holding user button, holding and releasing reset button, releasing button) but when I try to compile a sketch I get the following error messages:
Initialising bootloader.
Unhandled error: Timed out waiting for Bootloader response.
It seems that the mcu entered the bootloader mode but It could not upload the compiled program.
I have 4 cubecell AB02 and I experienced the same problem with all of them. After trying several times your “user-reset button” procedure I was able to upload my sketch on 2 cubecell Ab02 (with the other 2 there was no way out) but if I want to use these Ab02 I always have to press the user-rst button to upload the sketch. Is there a way to solve this issue ? To me it seems that 4 cubecell broken (or unasable) it is really a bad performance of this product. Thanks for any support

I have just received two new CubeCell Dev-Board V2 modules. The two boards booted OK and played ping-pong but when I tried to load another sketch, one of the boards consistently returned the Bootloader error being described in this thread—the other board loads sketches as expected.

On one occasion I managed to get the problem board to load the ChipID example sketch by holding the USER button then pressing the RST button, but I couldn’t get that procedure to work again, so now that board will only run the ChipID sketch—I cannot reload the Factory_Test sketch, or any other.

If I hold the USER button and press the RST button, the message

bootloader Rev 1.0

appears in the Serial Monitor, but with the exception of that one time when I managed to load the ChipID sketch, I just get the error:

Initialising bootloader.
Unhandled error: Timed out waiting for Bootloader response.

when attempting to upload sketches.

The fact that I have one board that works as expected and another that doesn’t would seem to suggest that the problem, whatever it is, is with the CubeCell board, not anything else like the cable (I’ve tried two different cables) or the host computer hardware or software installation.

I also have two CubeCell Dev-Board V1 and several CubeCell Dev-Board Plus modules and they have all worked as expected ‘out of the box’ (and continue to do so).

I have installed the latest version of the Arduino IDE (2.0.2) on macOS (10.14.5) and downloaded the latest version of the CubeCell software from GitHub.

Any further advice from Heltec (or anyone actually) on how to resolve this issue would be appreciated.

With the help of the information provided in this post, I seem to have found a solution, although I would suggest that there is clearly something wrong with CubeCell boards that display this problem.

If I press the USER button and keep it pressed, then press and release the RST button, then upload the sketch, I can reliably get sketches to load (and run).

If I release the USER button before the upload commences, the upload fails with the message we are all seeing.

If I release the USER button after the upload commences, but before the upload is complete, the subsequent automatic reset to start the sketch doesn’t seem to work. In this case, I have to manually reset the board again (press the RST button) before the sketch will begin execution.

I find that I need to keep the USER button pressed until the sketch has uploaded and commenced execution for things to work as they normally would (and should do, without having to hold down the USER Botton).

I have managed to do this now several times, with several different sketches, and it has worked every time. But if I try to do things as we would normally expect to (i.e. just upload a sketch, without any incantations for button pressing), things fail as previously described.



I just discovered the same workaround this morning as well and came here to post my findings, only to see that you’d already updated this thread!

To be clear, here’s what worked for me:

  1. Hold USER
  2. Press RST
  3. Release RST
  4. Program via CubeCellflash.exe -serial “COM3” firmware.cyacd (should also work from Arduino/Platformio, but was attempting to remove those as variables).
  5. Once programming completes, release USER

Board should auto reset and start executing newly flashed binary.

the same behavior with uploading code via VSCode and platformio.

I need hold USR, press RST, release RST, and still hold USR and upload sketh, release USR.
only this way it works.

I would say - it is not very convenient…

1 Like

1.upload sketh
2.hold USER as soon as possible
3.release USER when programming finished
:point_up_2:That works for me

Hello, @UniquePete It worked for me without presing the RST button, olye the USER one. Thanks for your post!