Wireless stick not working with provided example

Hello, I’m trying to connect my wireless stick to chirpstack server, but when I try this example (just with changed license to mine) I get this error:

ELF file SHA256: 0000000000000000

ESP32 MCU init...

abort() was called at PC 0x4008219e on core 1

Backtrace:0x400838b9:0x3ffb26700x40089085:0x3ffb2690 0x4008dd2d:0x3ffb26b0 0x4008219e:0x3ffb2730 0x40082774:0x3ffb2780 0x400d5898:0x3ffb27a0 0x400d5f11:0x3ffb27c0 0x400d1a72:0x3ffb27f0 0x400dc4bf:0x3ffb2820 

  #0  0x400838b9:0x3ffb2670 in panic_abort at /home/runner/work/esp32-arduino-lib-builder/esp32-arduino-lib-builder/esp-idf/components/esp_system/panic.c:402
  #1  0x40089085:0x3ffb2690 in esp_system_abort at /home/runner/work/esp32-arduino-lib-builder/esp32-arduino-lib-builder/esp-idf/components/esp_system/esp_system.c:128
  #2  0x4008dd2d:0x3ffb26b0 in abort at /home/runner/work/esp32-arduino-lib-builder/esp32-arduino-lib-builder/esp-idf/components/newlib/abort.c:46
  #3  0x4008219e:0x3ffb2730 in esp_flash_erase_region at /home/runner/work/esp32-arduino-lib-builder/esp32-arduino-lib-builder/esp-idf/components/spi_flash/esp_flash_api.c:541 (discriminator 5)
  #4  0x40082774:0x3ffb2780 in spi_flash_erase_range at /home/runner/work/esp32-arduino-lib-builder/esp32-arduino-lib-builder/esp-idf/components/spi_flash/esp_flash_api.c:1173
  #5  0x400d5898:0x3ffb27a0 in writelicense() at D:\/D:\\61722\\Documents\\Arduino\\libraries\\ESP32_LoRaWAN_VASR\\src\\Mcu.cpp:33
  #6  0x400d5f11:0x3ffb27c0 in McuClass::init(int, int, int, int, unsigned int*) at D:\/D:\\61722\\Documents\\Arduino\\libraries\\ESP32_LoRaWAN_VASR\\src\\Mcu.cpp:154
  #7  0x400d1a72:0x3ffb27f0 in setup() at src/main.cpp:166
  #8  0x400dc4bf:0x3ffb2820 in loopTask(void*) at /home/xxx/.platformio/packages/framework-arduinoespressif32/cores/esp32/main.cpp:42

My platformio.ini

platform = espressif32
board = heltec_wireless_stick
framework = arduino
upload_port = /dev/ttyUSB0
monitor_speed = 115200
lib_deps = 
	heltecautomation/Heltec ESP32 Dev-Boards@^1.1.1
build_flags = 

build_type = debug
monitor_filters = esp32_exception_decoder

What can I do? Did anyone experience this error?

1 Like

I have the same issue. @krystof18 did you find solution?
Just share my previous experience (not really a solution!), yesterday when I have this issue on Ubuntu, I switched to Windows and it actually works. However, now this issue happened again on both OS.

Unfortunately I didn’t. But your problem with ubuntu might be something, because I use linux too. I’ll try it on windows and let you know, but it’s weird that the same code worked for you on windows one time and the other time it didn’t.

Have you had any luck? Ran into the exact same issue while trying to set up my wireless stick with OTAA to use with my raspberry pi ChirpStack server/gateway.

I tried it using arduino ide not platfromio and it worked just fine

Hi, I have the same problem, has anyone found a solution?