Wireless Paper Examples?

The two Wireless Paper I ordered from Aliexpress ( 6 days) arrived (Had to order from Aliexpress after Heltec sent me a notice that the two Wireless Paper devices I purchased from them would arrive in 40 days…) BUT:
There is no Heltec ‘Wireless Paper’ board in Arduino
It uses an ESP32-S3FN8 + SX1262 Chipset like the V3 Wireless Stick but with a 212 X 104 E-INK display

Did someone at Heltec forget to update the 0.7 ESP32 library?
The Heltec boards arrived, Aliexpress just notified me they are shipping and should arrive by 8/31!
Buy from Heltec, save the month wait!

You will need to manually point to v0.0.8. In your board preferences, you will have entered a URL pointing to a file in the 0.0.7 release. You can manually change it to 0.0.8 and the Board manager will show an update.
There is some example flying around for the Wireless Paper, IIRC in the Heltec_ESP32 repository. I recently got my hands on one as well and managed to get the e-ink display going, haven’t looked further yet.

Thanks, that saved a few hours of Goggle-fu
After updating to .8 I now have a wireless_paper Board BUT:
File/Examples/Heltec-Example/Factory_Test/Wireless_paper_FactoryTest.ino Does not exist, the software they ship the board with is set for the EU, without the INO file there is no means to setup the WiFi server or the LoRa region.
This means powering on the wireless_paper is breaking the law, I am not allowed to broadcast on 868Mhz.

True, that one’s clearly missing. But the ingredients are scattered all around, just need to pick the right parts. The LoRa part is just like other V3/S3 boards, shouldn’t be too hard. I’ve got a working e-ink at least, if that’s what you are missing.

I purchased the device thinking it was like the ‘Stick’ with an E-paper display but when I requested the schematic I found out there is no access to anything, it is meant to be a display only device… Of course that was after ordering 4 of these things, 2 from Heltec then found out they shipped by ‘slow boat’ and 2 from Aliexpress, they have 5 day shipping. I may set it up as a AP and use a Stick Lite to talk to it.
NOTE: I discovered that the two boards I have came from Heltec NOT Aliexpress, Aliexpress just notified me the boards shipped with expected delivery 8/31!
Lesson: Buy from Heltec.

Here’s a factory test:


Unforgettably I’m not git enabled, I tried using Git desktop to update my local git, nothing.
I tried Arduino Library manager, nothing, no updates
I guess I uninstall everything and start from scratch…

Why would you need local git? I assume you have the Heltec package installed in order to compile for these boards, then all you need is copy the contents of the script from the webpage… no need to have it all cloned locally!

@bns I tried right mouse click copy on the link, what I got was the git information on the file. I deleted my old git and grabbed the current one with the ino file, when I opened it I found that this is not the software that is shipped with the Wireless_paper, this software sets up the display and creates a Webserver, no LoRa, no Sleep.
The other ‘factory’ software:

  • HelTec Automation™ WIFI_LoRa_32 factory test code, witch includ
  • follow functions:
    • Basic OLED function test;
    • Basic serial port test(in baud rate 115200);
    • LED blink test;
    • WIFI connect and scan test;
    • LoRa Ping-Pong test (DIO0 – GPIO26 interrup check the new incoming messages);
    • Timer test and some other Arduino basic functions.
      by Aaron.Lee from HelTec AutoMation, ChengDu, China
  • 成都惠利特自动化科技有限公司
  • https://heltec.org

I cloned it to try and figure out the src in response to the lack of a documented API

I somehow got the code Wireless_paper_FactoryTest.ino with image.h, but when I tried to compile them:

exec: “C:\Users\Kevin\AppData\Local\Arduino15\packages\Heltec-esp32\hardware\esp32\0.0.8/tools/esptool/esptool.exe”: file does not exist

Compilation error: exec: “C:\Users\Kevin\AppData\Local\Arduino15\packages\Heltec-esp32\hardware\esp32\0.0.8/tools/esptool/esptool.exe”: file does not exist
When I copy Z:\AppData\Local\Arduino15\packages\Heltec-esp32\tools\esptool_py\3.3.0\esptool.exe to C:\Users\Kevin\AppData\Local\Arduino15\packages\Heltec-esp32\hardware\esp32\0.0.8\tools\esptool\esptool.exe
It works but why did removing the Heltec ESP32 stuff and reinstalling it cause this? I checked on the Arduino link: https://github.com/Heltec-Aaron-Lee/WiFi_Kit_series/releases/download/0.0.8/package_heltec_esp32_index.json nothing has changed (it is listed as .0.0.7 STILL in the docs)
The net result with one of the Wireless paper boards I have:
But I did get it to compile and it did display the logo for a few minutes BUT the LoRa would not connect to my running Stick V3. With the serial monitor you can see it still is working but unable to connect to other LoRa device I have talking to each other… RSSI is always 0.