Wifi LoRa v2 unresponsive

I had a firmware programmed to it and it was running fine. the 3.3v wire pulled loose and I accidentally wired it to the ground. It obviously did not work and I realized my mistake, rewired it, and now it will not work at all. The board won’t run the firmware and I cannot upload new firware as I get the “failed to connect to esp32” error now. The board connects to my computer and is shown on COM5, the orange light will come on but it still won’t load the firmware. I tried the capacitor trick, tried to hit the prg button, but still nothing changes.

Have you check the 3.3v regulator chip that supplies the esp32 chip ? You may have blown that when you shorted the 3.3V line, if so you will near to check the board electronics.


Maybe you should check the current development board:

  1. Whether 3.3V is normal when connected normally
  2. Is 3.3V shorted to GND? Perhaps, as mentioned by Simon, the CE6260 of the development board is abnormal. You may need to replace this LDO.:sob:

Where is that located?

it’s here. I wish you all the best.