Wifi LoRa V2 stopped working - flash read error

I have a Wifi LoRa V2 board which was sending data every 10 minutes. Everything worked fine for a while but then the board stopped sending data. I hooked it up to the PC to check debug information on the serial monitor and all I get is:

    10:32:02.290 -> rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    10:32:02.290 -> flash read err, 1000
    10:32:02.290 -> ets_main.c 371 
    10:32:02.656 -> ets Jun  8 2016 00:22:57
    10:32:02.656 ->

I tried to upload my sketch again but get the following messages:

Sketch uses 800230 bytes (23%) of program storage space. Maximum is 3342336 bytes.
Global variables use 44224 bytes (13%) of dynamic memory, leaving 283456 bytes for local variables. Maximum is 327680 bytes.
esptool.py v2.6
Serial port /dev/ttyUSB0
Chip is ESP32D0WDQ6 (revision 1)
Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
MAC: 24:0a:c4:fc:c6:10
Uploading stub...
Running stub...
Stub running...
Changing baud rate to 921600
Configuring flash size...
Warning: Could not auto-detect Flash size (FlashID=0xffffff, SizeID=0xff), defaulting to 4MB
Compressed 8192 bytes to 47...

A fatal error occurred: Timed out waiting for packet content
A fatal error occurred: Timed out waiting for packet content

Is there a way to get my board working again ?

Thanks in advanceā€¦

I want to bring this up again - no answer yet. Can anyone give me a hint how to recover the board ?