WiFi_LoRa_32_V3_FactoryTest - LoRa not send packages

Hello everyone. I’m new here in the community, and I hope to get help with my issue, which I find quite strange…

Recently, I tested two Heltec LoRa V3 boards with the Meshtastic project firmware, and it worked perfectly without any issues in LoRa communication.

Now, as I try to revert back to the original/factory firmware, I notice that the boards no longer send the “hello” packets as they did before. They boot up, and after the Heltec logo, they perform a Wi-Fi network scan and stop there. Supposedly, they should proceed to a final screen mentioning the transmission of packets via LoRa and signal quality.

I’ve already reinstalled Arduino IDE 1.8.19 and libraries 0.0.7, and I’ve even tried using another laptop, but it still doesn’t work.

I even went back and tested the Meshtastic firmware to ensure that the LoRa antennas are functioning, and it worked without any problems.!

Please provide more useful information on whether the two board frequency bands are the same.

I’m only referencing this from memory so take that into account. I believe I had this same issue and from what I remember, of you look at the serial output from the device it complains about registering the device. From there you’ll go to some heltec site and put in the chipid that shows in the serial console and then that’ll register a key and then you type some command into the serial console and it’ll register and then work. I only had to do this once, and I’m not entirely sure why but I think has something to do with low level registering of the lora. Try that and let me know.


I think @ppcasm is right. You need to license the software.