WiFi Kit 32 v1 OLED not working with FactoryTest examples

I met some problems with my WiFi Kit 32 v1 board. (I checked against the official diagram and I’m sure it’s v1.)

After uploading the “WIFI_Kit_32_FactoryTest” example from the “Heltec ESP32 Dev-Boards” version 1.1.0, I can see messages in serial monitor saying “you can see OLED printed OLED initial done!” but the OLED does not work.
I also tried the ESP32\I2C_Scanner example which reported no I2C devices.

Later, I tried the GraphicsTest from U8g2 library with configuration (clock=15, data=4, reset=16), the OLED display worked well.

I have no clue how to further debug this. I would appreciate if you can help provide some suggestions.


(Chinese version below)
我有一块 WiFi Kit 32 v1的板子(参照官方文档确认过版本了)。
刷了官方的 FactoryTest之后 OLED是不亮的,Serial可以读到信息。
尝试刷了 I2C_Scanner但报告没有找到设备。

后来我试了U8g2的图形库 GraphicsTest,设置了 (clock=15, data=4, reset=16),刷完之后屏幕亮了,工作了。


在 工具->开发板 里面进行选择。

Thank you. Problem solved.

I was previously using the “esp32\Heltec WiFi Kit 32” from “esp32 by Espressif Systems” as board definition.
After installed and switch to “WiFi Kit 32” from “Heltec ESP32 Series Dev-boards by Heltec Automation™”, it works fine.

I check and run diff on the pin mapping, board configuration files, there doesn’t seem to be major differences. Still cannot find the root cause.
I wonder if other people met this kind of problem before.