WiFi Kit 32 MacOS driver issue - again


I am using Heltec WiFi_kit_32_v3. (I have four of these. All exhibit the identical symptom.) I connect it to Apple M1 Max MacBook Pro running Ventura 13.2.1. No USB device appears on my system. The module does not power up. I have three USB-C to USB-C cables. They all work fine to drive, for example, Samsung Portable SSD T7 and a few other such devices. I have downloaded and attempted to install the current ‘driver’ from the SiLabs site. (What a nightmare that is. After all the gyrations I have gone through to install it, I’m still not convinced it’s installed properly. I’m skeptical, at best.)

The first symptom to consider is that the device does not power up when I plug in the USB cable, as do all the other microprocessors I have. When I connect the module to a charged 3.7v LiPo battery, it powers up and runs the ‘factory installed’ (?) sketch, which displays your logo, initializes WiFi (although connection fails, as I expect it should), scans for and reports several WiFi stations in the vicinity, yada, yada, yo… then… it goes dark, apparently powering down, which makes it difficult to troubleshoot this issue.

So… my first questions are:

  1. Should I expect the module to power up when I plug it into a USB-C connected to my laptop or plugged into a hefty iPad pro charging adapter (known to supply power to all the other devices I have plugged into it.)

  2. Is there some way to ‘install’ a script that doesn’t go into a deep sleep or whatever mode it’s entering that (seems to) power stuff off? E.g., is there some magic like pulling designated pins up/down that will cause the board to restore itself to a state where it remains powered up?

  3. I have read other posts related to this issue here, on the SiLabs forums, and quite a few others I found. They all come down to either installing the SiLabs driver and ensuring I have a USB cable supporting my Mac’s connection. As I said earlier, I have done everything possible to install the current SiLabs driver, and I believe the wires are good. If you think the lines could be a problem, please provide specific information about a cable/product that IS supported and known/expected to work. I will buy it on the off-chance that it could matter. I could find one at Amazon, Digi-Key, Adafruit, or any number of such places, but that’s how I got the cables I have. If I (blindly) buy another and it fails, I’m no better off and out more money and time.)

Please advise.

Thank you!

I reinstalled the latest and greatest drivers from SiLabs web site. Install went cleanly so I assume they will work when the board powers-up from its USB-C port. Er… I am hopeful that it will work.

Why doesn’t the board power up? Again, all four of the boards I have do not power-up with the USB port but they do if a battery is attached. (With or without the battery, the USB port does not work.

So… my issue is resolved. I’m befuddled… but happy that connecting a usb-c-male to usb-a-female adapter cable in series with a usb-a-male to usb-c-male cable WORKED. I have NO IDEA why but I’m thrilled to move on.

I experienced the very same issue that you describe. And I found the workaround before reading your post. Actually, I would post a message but I searched if one was already posted about this topic before.
In my case, the problem is not resolved:

  • I tested with a colleague who plugged a WiFi LoRa 32 in its laptop running Windows using a USB-C to USB-C cable and the issue was the same.
  • The workaround is not scalable: we want to organize practical work sessions and it’s sure that a lot of participants will not have USB-C hub + USB-A to USB-C cable.