Unhandled error: Timed out waiting for Bootloader response

Hello I recently adquire a CubeCell Capsule:

I was following the configuration guide in order to run a LoRaWAN test in arduino IDE. I already installed the drivers for the bootloader and detect the port.

Silicon Labs CP210x USB to UART Bridge (COM3)

The cable I am using was used before for others heltec Lora devices and worked fine. For some reason for this CubeCell isn’t working properly, I compile the code, then I try to upload and I get this error:

Initialising bootloader.
Unhandled error: Timed out waiting for Bootloader response.

Maybe I have to plug the HDC1080 in the photo? I’m not sure what to do in order to fix this error.

you dont have to plug in a sensor for uploading a new sketch.
please try the following:

  1. unplug the capsule from usb
  2. hold USR key and plug usb back in
  3. try to upload your sketch.
1 Like

Ok, seems to work, now I get this error

[728] Failed to execute script CubeCellflash

Initialising bootloader.

Traceback (most recent call last):

  File "CubeCellflash.py", line 3, in <module>

  File "bootload.py", line 769, in bootload.main

  File "bootload.py", line 646, in bootload.BootloaderHost.bootload

  File "bootload.py", line 688, in bootload.BootloaderHost.enter_bootloader

  File "bootload.py", line 471, in bootload.BootloaderSession.enter_bootloader

  File "bootload.py", line 466, in bootload.BootloaderSession.send

  File "bootload.py", line 218, in bootload.BootloaderResponse.decode

bootload.InvalidPacketError: Expected Start Of Packet signature 0x01, found 0x0

bootload.InvalidPacketError: Expected Start Of Packet signature 0x01, found 0x0

Have you released the USR after plugging usb back in?

I’m sorry, I’m not following, what do you mean by USR key? I search in the board and I have these two buttons:


RST and USER, do you mean USER?

I mean the USER key.

By pressing the USER key when plugging and uploading I get

Initialising bootloader.
Unhandled error: Timed out waiting for Bootloader response.

You need to release the USER key after plugging usb in and before uploading

Oh I see, I did it, but I keep getting the same error… maybe the board isn’t working properly?

Have you connected the usb board in the right direction?
On the usb board and in the capsule is white dot, both must allign

Hello, yes I connected the board in the right direction, still getting this Timed out waiting for Bootloader response. I connected the board only and get the error too. Do you get this error if you connect the board only?

if you only connect the board there is nothing that could answer.
you have to connect the board to the capsule, the board is only a usb to serial converter.

if the USER key method does not work your capsule may be broken.

I have two with the same problem. can all them be broken?

After trying with another cubecell capsule using the same cable and board, this new cubecell worked… so… maybe my other cubecell is broken.

Are your two capsules tested in the same debugger?

The probability of the capsule itself breaking is very low, because the logic control part that enters the bootloader is not in the capsule, but on the debugger. The cause of the problem may be poor contact or oxidation of the pins. Try to use sandpaper to gently remove the oxide layer on the pin header surface may solve this problem.

After checking the microchip I didn’t find any oxidation in the pins, and compared to the others microchips of my capsules that work I didn’t find any special defect.

I change the microchip with other capsule and the capsule work, so this part might be damaged.

Unfortunately I have the same issue as @kordhrufan and @cvale on a CubeCell Dev Board (not a capsule).

Unhandled error: Timed out waiting for Bootloader response

USER button reset isn’t working. Is there an easy way to recover the bootloader (if thats the problem?).

WASN, Your method saved me a lot of despair. Many Thanks. Notice to disconnect the battery also, if you have one.

Hello Guys, I encountered same Problem After uploading Air quality Sensor example I was not able to upload anything Else,
Tried User Button, Tried Reset Button both on capsules and on boards but nothing happened.

When I put back Sensor of the last Sketch that I upload and let it start and I Could start reading parameters of sensor from Serial Monitor, After that I was able to upload New Sketch.

Not sure if this somehow helps anyone but that was the case with me

I encountered the same problems as others. I discovered that if I plug the sensor board (in my case CCS811) into the debugging board. Then plug the debugging board into CubeCell Capsule. The firmware upload works fine. However, if I remove the sensor board, then the upload failed with same error message as others have described.