TTN and CubeCell product not meeting Fair Usage Policy as standard

HI All I thought I would just highlight, that I have been setting “bool IsTxConfirmed = true” to “false” in all the code I use, due to the fact the product as standard configuration does not meet the Fair Useage Policy of TTN.
This is due to the fact that at most 10 downlink messages per day, including the ACKs for confirmed uplinks are allowed for each node. Having Tx confirmed set to “true” means that this rule is broken and would not meet TTN policy.

The current configuration of the Heltec CubeCell Board Manager (or WASN configurator script) does not allow the acknowledgement of TX to be set as off, as standard.
It would be good if the Board Manager Configuration and if possible the great WASN configuration Have the ability to set TX confirmed to False as standard and only allow it if configured.


1 Like

The next firmware version will have that option turned off by default.

Will take some days cause i hope to have fix for the OneWire sensors in the next release.

i have updated the repo.
now by default there will be only unconfirmed uplinks send.
you have to set the variable IsTxConfirmed to true to enable confirmed uplink.

Hi many thanks now even better. Simon

Thank you for including this feature.

the precompiled firmwares for the WASN configurator have now unconfirmed TX as default.
The new configurator can change this parameter

just insert this in the examples or you won code:

/* Indicates if the node is sending confirmed (true) or unconfirmed (false) messages */
bool IsTxConfirmed = false;

Thanks for your notice, we will look into the Policy and give solution next week.

Yes! that’s it! Thank you very much! We will add an option in Arduino menu.

Thank you for your fast response :grinning: