Sufucient IoT Hub Wifi not working

I received the IoT Hub last week and can get the ethernet to connect at boot time and the wifi once I have logged in as root using ‘bash yourssid yourpwssd 1’ as documented. However, the persitent version does not work. The file in relevant the directory is created by the command wpa_passphrase SSID Password > /etc/wpa_supplicant/user_wifi.conf, but is not executed on bootup. The Debian documentation also states that it should work. It must have disabled it in the code.

Please advise on how I can make this work, as the device is supposed to operate without being connected to a computer.

Wolfgang Daum

With the help of Heltec support I got the hub to work. The main thing was to flash the latest image and then follow the setup instructions. Thank Heltec support.

NOTE: the max micro SD card size is 32G.

W. Daum