STM32L151CCU6 LoRaWan failed with putty

Hi community,

I tried to run my new Node L151 with Lora SX1276. In my opinion I’m pretty far in the process (
I downloaded everything and also the .bin/.elf file on the MCU but get nothing, when I connect serial with putty. Putty can open the serial COM, but shows only blackscreen.

What I did already:

  1. Installed Cube IDE (V1.4.2) and Programmer (V2.4 due to no connection with V2.5)
  2. Read out the Chip ID and get the download for LoRaWAN_151CC_ADC_V1.1 (or LoRaWAN_151CC_V1.0)
  3. Opened the project in the IDE, made the changes in Commissioning.h (DEV_EUI etc.)
  4. Set the right Band (868) in the properties
  5. The LoRaWAN_151CC.ioc had to be coded (I clicked “Device Configuration Tool Code Generation”) - worked
  6. Still in the IDE - Running the Hammer with “Release” said that void SysTick_Handler is declared twice (in board.c and stm32l1xx_it.c). I commented out one (and one time also the other) -> then it deployed wonderfully
  7. Opened the CubeProgrammer connected the device and downloaded the .bin file (also tried with .elf).
  8. Reconnect the USB without pressing User-Button and get the COM3 for the board.
  9. But connecting serial with putty there is only a blackscreen :frowning: I expected to see an information about sending packages or so.

I tried also with the Projekt …V1.0, but then after downloaded the bin/elf-file the board won’t be recogniced as USB correctly an I can’t get a COM-Port anyway.

Can anyone see the mistake I do?



NODE151 has no hardware UART.

you can use CDC or Connect a hardware UART module.

Okay, in the Pingpong-Example I get a connection via usb and can define the parameters of the LoraWan. I thought I would get something over putty with the LoRaWAN_151CC_ADC_V1.1 Example too.
But you are right as I can see in my humble knowledge, the code doesn’t use the USB for debug or messages.
But how can I see if the device is working probably. I try to connect with TTN and tried over the OTAA and ABP method, but both without a connection.

There is one thing in Commissioning.h which I don’t understand:

#define IEEE_OUI 0x22, 0x32, 0x33
#define LORAWAN_DEVICE_EUI { IEEE_OUI, 0x00, 0x00, 0xAF, 0x00, 0xCD, 0x48, 0xDA, 0x2D }

Is this OUI somewhere in TTN or where can I get the correct value? Is it neccessary? Or can I just use the DEVICE_EUI without the IEEE_OUI in front?

yes, you can just use the DEVICE_EUI without the IEEE_OUI in front