[SOLVED]LoRaWAN conection of two ESP32 Heltec LoRa devices to Dragino LPS8


I have a problem. I am testing the connection of two ESP32 Lora Heltec devices to a Dragino LPS8 gateway using LoRaWAN. After performing the ESP32_LoraWAN Master library update I was finally able to properly work the connection of a device to the TTN network through the gateway using OTAA (using Arduino example of OTAA). The joining process must be tried 2 or 3 times but finally it is possible to join and it starts sending packages without problem. The drawback occurs when I try to link a second device, while the first one is operating, the joining process takes too long, between 5 and 12 attempts, and sometimes it appears to me that the device is joined (in serial messages of Arduino IDE), but in TTN I keep receiving only messages from the first device, I must retry the connection several times to finally get messages from both devices in TTN. Is this normal? Is it due to normal LoRaWAN operation? Is there a problem with the ESP32 devices or the gateway?. Thanks.

i dont know the LPS8 gateway. but if you can take a look at the LoRaWAN traffic log in the gateway it would be easier to help.

normally your devices should join both.
when they both try to join at the exactly same time it could take 2 or 3 join requests.

may i ask if you have created 2 devices on TTN? one device for each ESP32 with its own credentials?


I have contacted the provider of the LPS8 gateway (Dragino) about the problem I am having because sometimes one of my two ESP32 LoRa devices does not connect properly to the Gateway (LPS8 Dragino), there is no messages in Gateway traffic option, and TTN does not receive messages.

They inform me that I must configure my device to only work on Channels 8 to 5 of the frequency band that I must use US915Mhz (I’m in South America). How can I do to configure this ?, I am using the OTAA-OLED program but there is no option to configure this, I looked in the libraries that are used and I would believe that in the RegionUS915.h file it could be done, but I don’t know how to do it, Can you collaborate me to do this configuration?

Thank you

Ricardo S.

To fix the channels, need fix the channels mask of ESP32_LoRaWAN.cpp

Maybe this document make sense to you:


Thank you so much. The information was very helpful, with the change of the ChannelsMaskTemp [0] to the value 0xFF00 everything works fine, the connection of the two devices is very fast. Thank you again.

Nice to hear that.