[SOLVED]I2c scanner error 1/2aa

i used i2c scanner example with mpu9250(GY-9250), but in first try it shows me that:
No I2C devices found”
and then it gave me all i2c adresses, but with GY-91 it shows actual i2c adress


Which cubecell are you using?

Could you check your I2C connect pins?

1/2 aa node, already checked, and i try it on arduino uno, and it works

now i’ve tried mpu9255 and it still not work…

so i also tried to pullup 4.7kOhm resistors with 3.3v and SCL and SDA pins like in the library said

could you show your pin connect picture?

we have tested the code and it works fine.


Like in your picture, but i have another mpu

actualy purple one found in scanner but left and right of blues no

i’ve connect it to i2c pins SCL and SDA (39 and 40 #pins)

It seems that you are not using the sensor made by us. The sensor we make is no problem.

Yes, where i can buy some of yours sensors?

and i fix it, the fing is in using new 1/2 aa, because old one is one of my testing, so maybe pins are damaged or something else…

FSYNC Ground reference Frame synchronization digital input. Connect to GND if unused.

nCS should connect to the build in LDO output (tpy. 3.3v)

Maybe you can make a new order on our website.

here is link of the sensors:https://heltec.org/product/capsule-sensor/