OLED won't work when uploading through Arduino IDE

Hi everyone, i need help regarding on the issues i’m facing when working with [WiFi LoRa 32 (V2)]

I’m new to IoT development and recently I bought WiFi LoRa V2 which I then proceed to setup as guided here:

then I tried to upload this code to my board:

#include <heltec.h>
// the setup routine runs once when starts up
void setup(){

  // Initialize the Heltec ESP32 object
  Heltec.begin(true /*DisplayEnable Enable*/, true /*LoRa Disable*/, true /*Serial Enable*/, true /*PABOOST Enable*/, 470E6 /**/);

// the loop routine runs over and over again forever
void loop() {


The system itself seems to be working fine, yet the OLED display won’t show anything. Serial monitor only displays ???.

When i tried to upload it using arduino web editor, the OLED works, yet serial monitor still showing ??? when checked.

I’m currently using macbook pro m1 2020 13", Monterey 12.3 on python3. If you need more info I can certainly provide more. Help is very appreciated.