No GPS fix on CubeCell AB02S

Hello,

I recently received my boards from the Heltec Store and noticed that instead of de specified Air530Z chip, it has a chip with G12 on it.

I installed all the stuff in Arduino and tried a few example-sketches. But whatever I run, i do not get a GPS location fix. Not even if I stand outside under a clear sky.
Is it the chip? Is it the sketch? The combination?

Any help would be greatly appreciated.

Regards,

Guido
The Netherlands

The antenna is very bad and after first start the almanac must be loaded.

So find a location with good receiving conditions and wait, possible 30 minutes!

Greetings E_T

Thanks E_T, I am going to try with more patience :slightly_smiling_face:

Hi,

It finally worked. It took more than 1.5 hours for the first fix. Now it goes considerably faster. A few minutes max. Maybe the almanac gets stored somewhere? It does have flash.

I guess the chip, labeled G12 is in fact an Air530 or 530Z. Heltec can you confirm?

https://github.com/sivaelid/Heltec_AB02S_Mods/blob/master/Air530%20GPS%20Manual%20Text%20English.pdf

Here a translation of the chinese spec-sheet of the chip.