No boot. Reflash fixed problem?

Any ideas why a Heltec ESP32 LoRa 32 v2 would seem to have lost it’s program? Or not boot?

The board has been working flawlessly for weeks through multiple power cycles. Then today it would not boot up and run the program when power was applied. Hit reset button, nothing. Hit PRG button, nothing. Tried various power supplies, nothing. Tried applying power to various points (3.3v pin, 5v pin, USB), nothing. Reflashed the board and now it is working and can’t recreate the problem thus far.

The board when in use is powered by a high quality converter (3.3volt, 3.6 Amp). 5 volts is supplied to the converter. The converter takes it to 3.3 volts and supplies it to the 3.3v pin on the heltec board.

Any ideas what would have caused this behavior to happen? Because who likes non reliable hardware?

1 Like

Have you connected the serial port to see the print information?
The problem looks a bit like FLASH being erased by mistake. Do you have any functions for operating flash in your program?

Hi there :grinning: . Do not have any operators for dealing with the flash. An update on the latest. Put it back in the field and was working fine for a few hours then it started to randomly reboot. Going to replace the power source and double check solder connections.

Another thought… is there a resetable fuse or something of that nature that would be trigger by temperature?