M2808 - not updating. Orange LED flashing

I have installed few M2808. Cable connected. Fiber 1Gb speed.
Left overnight. Orange LED flashes.

miner release: 2021.07.30.0_GA

latest miner release: get failed

firmware: V1.2.7

It is not updating to latest software.

Any place where I can download latest software or suggestions how to solve it ?
Reboots does not help.
It seems that all of them stuck and do nothing.

Thanks !!

only way to fix this is to write email to support
there is no official way to update the firmware manually

Thank you (+for the reply on discord :slight_smile: )

I’ll let all of you know how much time it took them and what were the next steps - in case someone have similar problem in future.

Update: 24hrs + and still no reply to email sent to support.

I will keep you posted how long it takes / took to get this solved.

Fixed (!) - first hotspot fixed.
Got email from the support: "Hi, the firmware of the hotspot has been updated to the latest."

so it took them around 33hrs to get this fixed.

Not bad.

i have same problem with m2808 miner, v1.2.7 sitting for days and i no update of firmware… also, i wrote to technical support on their email support@heltec.ch and no replay for days atm… any help?