LoRa Node 151 unsupported device

Hello,

I tried to upload code with the STM32 Cube Programmer to the Heltec LoRa Node 151. To do so I followed the instruction guides. The device was detected as “STM32 Bootloader” in the Windows device manager but the Cube Programmer displays an error message that this device is unknown or unsupported.

What is the reason for this error message?

Thank you for your help.

Below I send you the details of the STM32 Cube Programmer:

22:22:13 : STM32CubeProgrammer API v2.1.0

22:22:21 : USB speed : Full Speed (12MBit/s)

22:22:21 : Manuf. ID : STMicroelectronics

22:22:21 : Product ID : STM32 BOOTLOADER

22:22:21 : SN : 6AE79D3265A0

22:22:21 : FW version : 0x011a

22:22:21 : Device ID : unknown

22:22:21 : Error: unknown or unsupported device (DevID = 0x0000)

22:26:57 : USB speed : Full Speed (12MBit/s)

22:26:57 : Manuf. ID : STMicroelectronics

22:26:57 : Product ID : STM32 BOOTLOADER

22:26:57 : SN : 6AE79D3265A0

22:26:57 : FW version : 0x011a

22:26:57 : Device ID : unknown

22:26:57 : Warning: Device is under Read Out Protection

22:26:57 : Error: unknown or unsupported device (DevID = 0x0000)

I think you need try another USB socket and use a better USB cable.

Also, you may need click this button before click the “Connect” button:

On the following photo you can clearly see that the Node 151 is displayed in the device manager.

Then I select the port and I click connect. The programm tells me that the error occured. I also used 3 different usb cables and the error arrived every time.

When I repeat the steps serveral times I always get the error message and in the log files the following text is shown:

12:40:31 : Error: unknown or unsupported device (DevID = 0x0000)

12:40:53 : USB speed : Full Speed (12MBit/s)

12:40:53 : Manuf. ID : STMicroelectronics

12:40:53 : Product ID : STM32 BOOTLOADER

12:40:53 : SN : 6AE79D3265A0

12:40:53 : FW version : 0x011a

12:40:53 : Device ID : unknown

12:40:53 : Warning: Device is under Read Out Protection

Did you click the sync button before connect?

Yes of course I clicked on the sync button.

In the next step I will try to download the firmware with the ST programmer.

Try to use a better USB cable, and try to use another USB socket or another computer.

I beat my head on a wall trying to figure this one out. I know this is an old post but if someone here finds it useful… not all USB cables support Serial connection, some only charge power. I tried maybe 5 USB cables before I dug one out that would support Serial connection.

Can you please try to uninstall all relative drivers and install the “STM32 ST-LINK Utility”, that software included all relative drivers.