HTCC-AB01 not joining on the ttn network

hello, I have a problem when trying to connect my HTCC-AB01 module to ttn, I have my own gateway and I have problems because my module does not connect, I only get a joining message and it does not connect, it only appears that it tried to do the join, this in OTAA mode, I already tried in ABP mode but the message of “confirmed uplink sending” appears, I already registered my gateway and it is connected, I already made my application in ttn, and registered my device, check the parameters devEui, appEui and appkey, they are correct, they are the same ones that ttn gives me when registering the device, I am using the LoRaWan example code from the development environment for arduino, I have been trying for a few days and I have not been able to make it work, my gateway is made with the LoRa / GPS hat for RPiv1.4 with a raspberry pi 3B +, using the code in the github repository: https: //


From the information you have provided so far, we can’t find the problem.

Can you try this code?

Could you show the tools menu for us? Like this:

Hi, @6dfablab I have recently purchased a HTCC-AB01 myself and have a very similar setup and situation; have you been able to configure yours? I have also registered my device with both OTAA and ABP, double checking the devEui, appEui and appKey are all correct. I have also tried multiple codes off CubeCell examples for Arduino. I would appreciate any help or suggestions, thanks in advance!
Edit: I would also like to add that I have the correct board and region selected in the tools dropdown menu, all other settings are default. @jasonXu