HT-M2808 LAN stopped working

I have HT-M2808 hotspot which was working OK. It was turned off for about a week.

After I connected it through POE splitter (D-link ‎DPE-301GS) the ethernet port does not work.
Ethernet port LEDs do not blink, hotspot does not appear in my router devices list.

I managed to switch the hotspot to WiFi and it works OK through wifi.

Any Idea if the LAN/ethernet connection can be fixed?
I later connected to the same D-link POE splitter another hotspot and it is working OK so I don’t blame the splitter.

I tried resetting the hotspot, I also tried restoring through dashboard.
Firmware version is the latest 1.1.6.


HT-M2808 does not support POE, you can try to use ordinary network cable to see if it works normally.

It does not work normally.
I tried using ‘ordinary’ cables, several cables.
I connected it directly to my router, it did not work.
I tried connecting to ethernet switch, LAN still does not work on that hotspot.

Does the LED light of the network port light up?

After connecting power to hotspot LEDs of the network port light up for about 2-3 seconds and turn off.
After that network port LEDs do not light up (network cable is plugged into the port).
Disconnecting network cable and plugging it in does not change anything.

Maybe the Ethernet part is malfunctioning, Do you mind using WiFi to make it work? If you mind, you can contact support( to repair or replace it for you.

I can configure the device to use WiFi.
Do you mean if i turn on WiFi support can diagnose something remotely?
Or do I have to contact support to send the unit back to China for repair or replacement?

You need to contact support to send the hotspot back to China.