HELTEK WIFI KIT32 crashes using BluetoothSerial library

I tried the example file “SerialToSeriaBT” but the module crashes and reset at the very startup with thi mesage. Any solution ?

ets Jul 29 2019 12:21:46


configsip: 0, SPIWP:0xee


mode:DIO, clock div:1


ho 0 tail 12 room 4
entry 0x400806a8
Guru Meditation Error: Core 0 panic’ed (LoadProhibited). Exception was unhandled.
Core 0 register dump:
PC : 0x400df7dc PS : 0x00060930 A0 : 0x800dfe7d A1 : 0x3ffd0120
A2 : 0x3ffdea88 A3 : 0x3ffd0198 A4 : 0x00000001 A5 : 0x00000001
A6 : 0x00060b20 A7 : 0x00000000 A8 : 0x00000000 A9 : 0x3ffd0120
A10 : 0x00000003 A11 : 0x00060b23 A12 : 0x00060b20 A13 : 0x3ffd01a0
A14 : 0x000f1400 A15 : 0x3ffdea88 SAR : 0x00000020 EXCCAUSE: 0x0000001c
EXCVADDR: 0x0000002c LBEG : 0x4000c2e0 LEND : 0x4000c2f6 LCOUNT : 0xffffffff

ELF file SHA256: 0000000000000000

Backtrace: 0x400df7dc:0x3ffd0120 0x400dfe7a:0x3ffd0170 0x400d6215:0x3ffd0190 0x4008f4d2:0x3ffd01c0


Same problem here. i have tried all kinds of things and nothing seems to work.

Try upgrading to the latest version 0.0.7.

update what library? it seem all updated here

See this document to reinstall https://docs.heltec.org/en/node/esp32/quick_start.html

thanks but only 0.06 is available image

Input the last ESP32 package URL: https://github.com/Heltec-Aaron-Lee/WiFi_Kit_series/releases/download/0.0.7/package_heltec_esp32_index.json