Heltec WiFi Kit 32 revision2 not connecting to Blynk IoT server

I am looking for help with the following issue. I am running a program developed with Arduino IDE in a ESP32 dev kit with Blynk IoT. As far as the unit is an ESP32 dev kit or in an HELTEC WiFi Kit 32 version1, it runs without any problem. I recently bought two Heltec WiFi Kit that happens to be revision 2. With the new version the program keeps trying to connect to the server (where it is the Blynk Cloud server or my local server).
I tried a small example sketch to verify if the problem can be my app. I use the LED_Blynk example under Example/Blynk/Widgets/LED/LED_Blink. This sketch just turn ON & OFF a Led widget in my iPhone. Heltec version 1 runs perfectly, Heltec version 2 is unable to connect to the server.
This is what I get when running the sketch

[3165] Connected to WiFi
[3166] IP:
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
//_, /////_
__/ v1.0.0-beta.3 on ESP32

[3172] Connecting to
[8173] Connecting to
[13174] Connecting to
[18175] Connecting to
[23176] Connecting to

I also notice this message before the compiler upload the code

esptool.py v3.0-dev
Serial port /dev/cu.usbserial-0001
Chip is ESP32-D0WDQ6 (revision 1)
Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
Crystal is 26MHz

I dont know if it is relevant but the compiler does not recognize the chip as revision 2, but is is rev 2. Also the IDChip sketch reports revision 1.

Any suggestion will be great. Thanks


Maybe you can compare the hardware schematic:

And run thisDevelopment environment:

Thanks for you reply.

Comparing hardware schematics do not give me any idea of what the problem could be.

The Development Environment from Aaron Lee is exactly the one I have installed.


could you post your code? I will test it.

It may also be this similar problem:

I am testing the board without any breadboard at all. Just plugged to the USB cable.

In this is the sketch

Download latest Blynk library here:

Blynk is a platform with iOS and Android apps to control
Arduino, Raspberry Pi and the likes over the Internet.
You can easily build graphic interfaces for all your
projects by simply dragging and dropping widgets.

Downloads, docs, tutorials: http://www.blynk.cc
Sketch generator:           http://examples.blynk.cc
Blynk community:            http://community.blynk.cc
Follow us:                  http://www.fb.com/blynkapp

Blynk library is licensed under MIT license
This example code is in public domain.

Blynk using a LED widget on your phone!

App project setup:
LED widget on V1

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial

#include <WiFi.h>
#include <WiFiClient.h>
#include <BlynkSimpleEsp32.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = “authorization number from Blynk”;

// Your WiFi credentials.
// Set password to “” for open networks.
char ssid[] = “myssid”;
char pass[] = “mypassword”;
char server[] = “x.x.x.x”; // IP for Local Cloud Server
int port = 8080;

WidgetLED led1(V1);

BlynkTimer timer;

// V1 LED Widget is blinking
void blinkLedWidget()
if (led1.getValue()) {
Serial.println(“LED on V1: off”);
} else {
Serial.println(“LED on V1: on”);

void setup()
// Debug console

//Blynk.begin(auth, ssid, pass);
//You can also specify server:
//Blynk.begin(auth, ssid, pass, “blynk-cloud.com”, 80);
//Blynk.begin(auth, ssid, pass, IPAddress(10,246,1,237), 8080);

WiFi.begin(ssid, pass); // Non-blocking if no WiFi available
Blynk.config(auth, server, port);
Blynk.connect(); //Returns true when connected, false if timeout have been reached. Default timeout is 30 seconds

timer.setInterval(1000L, blinkLedWidget);

void loop()
if (Blynk.connected()) { // If connected run as normal
Blynk.run() ;timer.run();

else {Serial.println(“no connected”);


When using this board selection, compiler report an error and stop

But if use this board selection, then it is fine but board does not connect to Blynk

I am wondering if I am really using Aaron Lee environment as you avised


“ESP32 Arduino” :It is the official development environment of ESP32. TThe reason why our development board model appears is because we submitted a PR to the esp official and passed it.

“Heltec ESP32 Arduino”: it is Aaron Lee’s(Heltec’s) environment.

I just noticed that holding the board with my fingers after pressing the reset button, it does connect to the server and keeps running until I release the board. Just releasing the board stop the connection.
Does it has any meaning to you?

jasonXu any hints that may help on this?

Did you managed to run my code?

JasonXu, I just verified that the problem is more basic. If I run your example Factory Test, with my wifi credentials, it does NOT connect to wifi. The rest of the test, detecting networks an so works fine.

Recently I received from a Chinese vendor a perfect clone of your wifi kit 32 rev 1. It works fine for me.
Regretfully I will not be buying any more Heltec product.
You may close this post if you wish