Heltec HT-M2808 with no activity


Maybe someone could help me. My Heltec was shipped on Dec 15th and I registered it on the 26th. Hotspotty shows is is synced, but Explorer shows it is still sincying. For the first two days since registration it worked Ok, but since then activity has decreased substantially and from yesterday it has done almost nothing… Last mining reward was on the 30th morning. Dashboard shows the following data.


Any help?


Connected to Blockchain: yes
Dialable: yes
Height: 1,160,786
Last Challenge: 2021-12-30 07:47 PM
Firmware: 2019.11.06.0
App Version: 3.8.5

Hi, I am having the same issue. Plugged it the same day on the 26th, it seemed to be working and now it’s doing almost nothing. It says syncing on the explorer but appears to be synced in the app. :frowning:

Hi, after trying many alternatives but not solving the problem, I switched the main router off and on again after 10 seconds. Bingo! The hotspot started mining again.

Hope this simple solutin will help you too.

Tried this but didn’t work. I have the unit from before December so maybe it is deffective.

Sorry… this unit that you have Lorraine… will most likely be defective :no_mouth:

I have the same issue. I have plugged mine in and it has connected. However, it has not witnessed anything. It also shows not relayed in the web interface, but relayed on helium.com. The interface flips around sometimes to relayed though. I was trying to update the network to connect to my modem instead of my wirleless router and cannot connect to bluetooth any longer. I cannot get the blue light to flash. I restart it and I have tried starting bluetooth in the web interface with no success.
I am concerned about this unit being defective. Is there a way to know? Was there a bad batch?
Witty Wintergreen Raccoon