ESP32 LoRa (V2.1) without a component

Hello everyone,

I’m a student and a beginner on LoRa and I’m using a Heltec ESP32 LoRa (V2.1) from my university. It’s an used MCU and I observed that there’s a missing component below it (I wonder if some former students broke it). Is there any reason for removing this component ? (3 out of 4 ESP32 LoRa from my university don’t have this same component!!!). And what is it, a cristal ?

I’m trying to run some codes with Arduino IDE and receiving Flash Error:

Warning: Could not auto-detect Flash size (FlashID=0xffffff, SizeID=0xff), defaulting to 4MB
A fatal error occurred: Timed out waiting for packet content

I’m almost sure these errors are being caused because of the malfunctioning of the hardware.

Can someone confirm my thoughts ?

This is a picture of my hardware:

This is a picture of the original hardware:
(Since I’m a new user I can’t upload more than 1 pic, so here is the link showing a “normal” ESP32 LoRa V2.1)

Thank you!


This is a filter capacitor. Removing this capacitor may affect the development board to automatically enter bootloader mode(Unable to download the program normally).

The current way is to manually enter the bootloader mode.

Before powering on the development board, Press and hold the PRG button first. After successfully powering on, release the PRG button.

And how do I know it is"succsessfully" powered on ?
I tried to keep holding the PRG button before connecting the microUSB, release the button and then upload with Arduino IDE. The error still happens.
I also tried to keep pressing it forever, but after the “Connecting…” timeout the error occurs.

I’ve read about connecting a 10uF eletrolytic capacitor between EN and GND, but i didn’t find the EN pin on WIFI LoRa 32(V2.1) Pinout Diagram.