ESP32 board manager 0.0.4rc1 failed to load

Hi Arron / Heltec team.

I have today tried today load board manager for the Esp32 V2 but the latest version does not load. It gives an error as per the screen shot below. Can this be fixed so we can use the latest one ?


I experienced the same problem. It would also be useful to know what changed in the failing version.

Sorry about this problem. I had fixed it.

I still can not load the ESP32 board manager. Here’s what Arduino IDE rver 1.8.9 reports:

Skipping contributed index file C:\Users\William\AppData\Local\Arduino15\package_heltec_esp32_index.json, parsing error occured:
com.fasterxml.jackson.databind.JsonMappingException: Unexpected end-of-input: expected close marker for Array (start marker at [Source: (FileInputStream); line: 2, column: 15])
at [Source: (FileInputStream); line: 339, column: 6330]
at [Source: (FileInputStream); line: 339, column: 1] (through reference chain:[“packages”])

I looks like the final curly bracket closes out the curly bracket on line 3 not the curly bracket on line 1. The final bracket ‘[’ on line 228 closes out the bracket on line 9 not the bracket on line 2.

Hi I reloaded Arduino as had a few issues now came to load heltec esp32 board manager and none of it loads step 1 or Step 2. I also tried the cube cell board manager and that load fine so some major issues on heltec Esp32 board. I may try to load via github tomorrow. Simon

I am really frustrated with this very same problem. First it’s the JSON Syntax. I fixed it and uploaded it here to use it myself.

But now it seems it still doesn’t work. The Github option also doesn’t work because there is no .gitmodules file to include AzureIoT. I added it manually from the esp32 repo only to encounter more problems. I really have the impression all these software errors are intentional!!

The lastest board manager URL:
Still not working, and I have tried other board’s URL which worked pretty well, seems that the problem happened on yours.
Hope your team can solve it ASAP, don’t waste our time, we really enjoy this board

Hi, there

I checked this problem this morning, because the network really very very very bad in my home, very slow when I tried to use GitHub or download from an aboard server (less than 2Kb :joy:).

I will fix the problem in my office tomorrow morning.

Sorry for our fault:frowning_face:


Hi looks to be working now I can load a 0.0.4 now and now with out RC1 tag