Error on 3 of 4 Heltec lora 32 modules

I bought 4 Heltec lora 32 modules. They all worked fine first but now 3 of them can not load any new code. They all give the error :" A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header".
The code which is on them keeps on running ok but cannot be updated.

It seems they do not go to receive mode. When I connect through USB cable.
I tried:
-different cables, comports, speeds and different computers. Same error.
-to conect directly to tx / rx pins. Same error.
-power supply is stable at 5 volt.
-pushing buttons on or before upload.

Any idea how to solve this? Soon I need to buy more modules but if this cannot be solved it will not be Heltic😔

When the words connecting… Appear on the interface, press and hold the boot button. When burning appears, you can release it.

Tried pressing every button. Holding, releasing at different moments. No result.

Do you use its pins? Some pins affect it when downloading.

Have tried it with nothing to any pin. Also tried to connect Dio0 to Gnd. No change.
I found on the internet that sometimes conecting EN (pin? ) on a esp32-wrom helped. But I do not know whether my lora-32 has that pin.

Do you pull GPIO0, GPIO2 or other pins high or low in the code?
You can try to press and hold “PRG” and then power on via USB.

NO in the code that is on it. As is it won’t load new code I cannot try something in the code.
Yes I tried pushing buttons.

Does your serial port print any information when you press the “RST” button?

No i triec it and it does not show any output.

Didn’t you add any print information to the program that was successfully downloaded last time?
You try to open the serial port, keep pressing the “PRG” button, press the “RST” button once, then release the “PRG” button, Check whether the serial port prints “waiting for download”, if not, there may be some problems with the serial port.

I found this in a ESP32 forum:

However, it refers to the EN pin of the original ESP32, but the LORA 32 does not have that pin accessible for the user.

Regards Achim

From the official manual, we can know that the CHIP_PU pin is the EN pin of the chip.

Refer to the LoRa32 schematic diagram, the CHIP_PU pin corresponds to the “RST” button and is pulled up to 3.3V.

I have tried:

  • pressing button(s) as suggested: no change, no output.
  • putting a condensator between RST and GND: no change.
  • Several usb cords and pc’s.
  • update al kind of drivers to serial port

I want to thank you for your suggestions but I am out off patiant. So these go into the bin.

Kind regards