CubeCellFlash tool not working in Linux Ubuntu :(

Hi

I’m trying to try one of the sample codes avalaible for my Cubecell 1/2AA but flashing tool doesn’t work on my system (Ubuntu 20.04 with Arduino IDE). If I run CubeCellFlash program in command line it looks to work, just complains about missing argument.
If I copy/paste the command line tried by Arduino IDE at end of compilation it fails as it does in Arduino IDE. Any ideas what’s the problem ?
Logs when trying to run it by hand

vincen@Kubuntu-portable-de-Vincen:~/.arduino15/packages/CubeCell/tools/CubeCellflash/0.0.1$ ./CubeCellflash -serial /dev/ttyACM0 /tmp/arduino_build_359224/CubeCell_HalfAA_REGION_EU868_RGB_0.cyacd
Traceback (most recent call last):
  File "CubeCellflash.py", line 3, in <module>
  File "bootload.py", line 766, in bootload.main
  File "bootload.py", line 593, in bootload.make_session
  File "site-packages/serial/serialutil.py", line 599, in setDTR
  File "site-packages/serial/serialutil.py", line 469, in dtr
  File "site-packages/serial/serialposix.py", line 636, in _update_dtr_state
BrokenPipeError: [Errno 32] Broken pipe
[28164] Failed to execute script CubeCellflash

Does /dev/ttyUSBX exist? Does it connect to Cubecell?

On my linux system it shows up as /dev/ttyACM0 instead of ttyUSB as my ESP devices.and listed as:

STMicroelectronics Virtual COM Port

in system so looks to be good I guess no ?
Tried with minicom to communicate with module using AT command but not really any success :frowning:

I don’t think it’s a tool problem.

could you confirm do you enter the bootloader mode?
https://heltec-automation-docs.readthedocs.io/en/latest/cubecell/frequently_asked_questions.html

If I try the procedure with user/reset buttons I don’t have anymore serial port showing up in my linux but in lsusb I see that:

Bus 003 Device 040: ID 0483:df11 STMicroelectronics STM Device in DFU Mode

so module working properly no ? tried with both cubecells 1/2AA I have and both shows same behaviour !

this is normal. When the following statement is displayed, you can download the program normally
Bus 003 Device 040: ID 0483:df11 STMicroelectronics STM Device in DFU Mode

oki but it’s not working too ! First it doesn’t display as a regular serial port so in Arduino IDE there is no program port selected and secondly it fails exactly the same as previously :frowning:

I’m also very confused as your online documentation clearly states you just need to plug the cubecell in USB with computer without pushing any buttons on board ! and that I should see a serial port shows up which was what I was trying first !!

sorry, I didn’t see clearly before. this is STM32 device. our cubecell is not stm32 device.
Please compare the pictures:
%E5%9B%BE%E7%89%87
%E5%9B%BE%E7%89%87