Cubecell module / unable to upload sketch (solved)

Hi all,

I would kindly ask for help. I am just testing CubeCell module (not a board). I connect VCC, GND, RX and TX and I would like to upload a arduino sketch. I am able to to communicate with module using at commands but unable to upload a sketch. All the time I got an error “Unhandled error: Timed out waiting for Bootloader response.”

What i am doing wrong? Is it necessary to init the ability to upload sketch somehow? like connect some pins or so?

Hello,

Are you using the debugger? and have you tried with different USB cables?

But I have also a very similar problem, same error “Unhandled error: Timed out waiting for Bootloader response.”
I’m using the debugger board and tried with 3 different USB-cables on two computers, but don’t even get anything out from the serial console… debugger connected as the white dots marked.
Any ideas what could be the problem? debugger or board broken? or something else I can try?

The dev board is working fine, so not a driver problem and usb cables seems to be okay also.

Hi,

I am able to communicate using serial interface - everything ok, I can send the at commands and get response however I am unable to upload arduino sketch

Update: is it due to my gpio0 is floating? Is gpio0 used as flash button?

Tie gpi0 to ground when powering the board and try to flash.
Are you shure you have the “active” arduino enabled module?

Thanks @wasn.
I bought arduino enabled. Am I able to check using AT commands if it is really so. (Time-to-time issue happens and maybe heltec sent me wrong version). Today I will try it with GPIO to ground. Will update asap

Ok, guys - finally solved. To flash CubeCell module the bootloader must be activated. To activate it the GPIO0 must be connected to GND during startup. That’s the whole secret :).
@wasn - thanks for your support.

1 Like

Thanks @kovi44 I was just starting to hit this issue.