CubeCell library manager & board manager

I have very good success using WiFi LoRa32 dev board to integrate various sensors.

Now I try to move the sensors to the CubeCell HTCC-AB02 boards. I like this CubeCell board because it has excellent low power operation. However, the CubeCell development framework seems to have more trouble for me. Here are my questions:

  1. After I installed v1.3.0 CubeCell board manager, I tried to run a few example code. I always got some compiler code

  2. I2C_scan example:
    exec: “/bin/arm-none-eabi-g++”: file does not exist
    Error compiling for board CubeCell-Board Plus(HTCC-AB02).
    Could not find boards.txt in C:\Users\p_hsi\Documents\ArduinoData\packages\arduino\hardware\mbed\1.3.2. Is it pre-1.5?

  3. I noticed that there is no library manager available for CubeCell in Arduino IDE. Is this the problem? How to install library correctly for CubeCell development framework?

1 Like

You can install it through the following steps.

Hi Navi: Thank you for your quick response. I followed this instruction and successfully installed the CubeCell board manager.

  1. However, when I check included library:
    sketch -> include library -> library manager -> installed
    I did not see a CubeCell library installed. (see picture)

  2. When I tried to manually include the downloaded ZIP file folder “CubeCell-Arduino-1.3.0” from Heltec by the follow sequence :
    sketch -. include library -> Add .ZIP library
    I got an error message:
    “Specified folder/zip file does not contain a valid library”

  3. I looked at the “CubeCell-Arduino-1.3.0” folder, it does contain a \libraries folder with many sub-folders. However, inside this \libraries folder, it does not have the common “library” JSON and Properties source file.

  4. I compared the Heltec_ESP32-master ZIP file. It has all the correct JSON & Properties source file. That is why the library can be installed easily via library manager.

Please advise how to install CubeCell Library in Arduino IDE correctly. Thanks!!

Whether to add the correct json file.

1 Like

I installed the correct V1.3.0 package as you suggested from Heltec website via board manager. Here is the screen shot of [file]->[preference]

However, the library manager does not show any CubeCell library installed.

From [tool] -> [Library manager], I only see 3 Heltec libraries (ESP32, ESP8266, eink). The CubeCell library is not installed.

Please advise how to install CubeCell library?

1 Like

click here

Check if there are Cubecell related json files

I do see the package_CubeCell_index.json under \user\p_hsi\document\ArduinoData\ folder (shown here)

So what do I need to do next?

1 Like

You try to search cubecell.

Search for CubeCell in Boards Manager instead of Library Manager.

I already installed the latest CubeCell board manager V1.3.0 as you can see from the previous screen. But when I try to compile example code, such as [display]->[OLED]->[OnBoardOLED_AB02(SH1107_I2C)], I got the following error message:

exec: “/bin/arm-none-eabi-g++”: file does not exist
Error compiling for board CubeCell-Board Plus(HTCC-AB02).

I have a feeling that I did not place the CubeCell library in the right location.


Another question:

I also found two sets of packages for CubeCell HTCC-AB02 board:

  1. ASR650x-Arduino-1.3.0-BoardManager
  2. CubeCell-Arduino-1.3.0

They appear to be similar. Which one should I use?


Have you used Git to install a development environment? You can delete the related files installed by Git, and only keep the development environment installed by the Boards Manager.

No. I did not use Git to install. I only use board manager to install the development environment.

I had a couple CubeCell boards since last year and did a number of project using the older version V1.1.0 board manager. They worked okay (only a few warning message). I really like the CubeCell board and plan to order more for my new project.

Since I installed V1.3.0 a few weeks ago (and deleted the older version), I ran into a lot of complier error. None of the previous code will work any more.

Is there any way I can download the older version V1.1.0 so that I can recover the previously working project code? Right now I am stuck until I can resolve the complier error with V1.3.0 version environment.

I uninstalled the existing CubeCell V1.3.0 board manager.

Can you provide me a step by step instruction on how to install the CubeCell V1.3.0 board manager? After that, can you show me how to install the libraries needed for the CubeCell board?

Here is the directory of my development environment:

  1. CubeCell code in D: drive.

  2. Arduino IDE in C: drive

  3. Newly downloaded V1.3.0 package for CubeCell

I remove the entire Arduino IDE system and re-installed a fresh one in my PC. Then I installed the V1.3.0 CubeCell board manager.
Good news,
When I run the example code of display-> OLED->OnBoard_AB02(SH1107_I2C) ->DrawingDemo. There is no compiler error.

Bad news,
But when I upload the code to the CubeCell board, I got the “Unhandled error: Timed out waiting for Bootloader response.”

Any suggestion?

You can use the following operations to manually enter the bootloader, press and hold the USER button> press the RST button> release the RST button> release the USER button.

I tried to burn bootloader. Got the following error message:

Error while burning bootloader.
at cc.arduino.packages.uploaders.SerialUploader.burnBootloader(

I found out the upload problem was due to faulty USB cable. After re-install Arduino IDE. now both CebeCell and WiFi Kir 32 boards work perfectly. Thanks!