CubeCell HTCC-AB01 join failure on AU915

I am using the HTCC-AB01 in Australia on AU915 using sub-band 2. There are multiple gateways near my node and each packet from my node is reliably received by multiple gateways however join attempts, using the provided sample LoRaWAN.ino application can take a long time to succeed.

The LoRaWAN.ino application attempts to join every 30 seconds however it can take 15 minutes or longer before the join is successful.

This is the channel mask I am using:

/LoraWan channelsmask/
uint16_t userChannelsMask[6]={ 0xFF00,0x0000,0x0000,0x0000,0x0000,0x0000 };

I have also tried this one:
uint16_t channelMask[] = { 0xFF00, 0x0000, 0x0000, 0x0000, 0x0002, 0x0000};

And I have also tried calling the setSubBand2() function example as posted on this forum in another CellCube thread for AU915 but the result is always the same, it never succeeds on the first join attempt and can easily take 20 to 30 attempts before finally succeeding.

Any suggestions as to what I should try next?

There are two reason may cause this problem:

  1. The parameters in your LoRa server may not match setting in LoRa node (DevEUI, APPKEY, etc.), you need double check that;
  2. You gateway’s listening frequency didn’t match you node’s sending frequency, can you upload the global_conf.josn file in your gateway? That will help analysis the reason.

The keys must be correct or the joins would not eventually succeed.

I am not using my own gateway. My LoRaWAN packets are received by several gateways in close proximity by my node. Here is an example where you can see the node has been seen by multiple gateways with good signal strength but the joined fails:

Here is the same screenshot taken 4 minutes later after the node joined successfully:

This appears to indicate there is some other issue.

Can you make list about all those uplink frequency?

From the oldest
Unsuccessful joins:

Successful Join:

There is no problem in the frequency setting. It means the channel mask of node is correct.

Refer from the picture you sent, it means the data sent by the node are successfully received by server, but server don’t allow this node join.

I think this is the problem:

This Device EUI is the default EUI in our example code, I believe many users already registered that… Delete this node and use generated EUI.

1 Like