Cubecell: Bootloader error?

When I’m trying to execute examples on the CubeCell board, I get the error:

Initialising bootloader.
Unhandled error: Timed out waiting for Bootloader response.

I have read the Most Common Problems page but I don’t understand if this is addressing the problem I am having. Do I need to “Access Bootloader Mode” in order to be able to “Initialize” it? It says that if I do it, I “can’t Download Firmware anymore”. What does this mean? I’m guessing it is not about not being able to upload sketches anymore.

But more importantly: Why should I need to short two pins in order to be able to upload sketches? I have worked with the WiFi Esp32 V2 boards so far without problems.

Thank you for your help.


I try to read between the lines :wink:
You are using the arduino IDE and a cubecell dev board?
Drivers are installed?
Com port is found?
Have you tried to open a serial console (115200,8,n,1) you should be welcomed with a heltec prompt.

I had this one time and unplugging and plugging it in again helped.

1 Like

Silly me. The cable I was trying the CubeCell with did not support data transfers. I just tried another cable and it worked!