Cubecell AB02S Not Receiving Data?

Hi, I just started using my new AB02S board and I have been having some issues with getting the gps to work. Whenever I run any of the sample programs in Arduino, all the gps information come up as 0. I haven’t changed the sample code at all except for a line to fix the oled display. Also, weirdly enough, it is able to display the gps time after a few minutes but nothing else. I’ve also tried waiting outside a few minutes with the antenna attached but I still can’t get any data. Any ideas?


This is what the output looks like before it connects to gps time

Update: Wow, it actually started working after a few hours of just running the program. However when I reset the device, It just kept on doing the same thing. Does anyone know why it would take so long to start working?

If the GPS information shows 0, it may mean that there is no GPS signal. You can try it in an open place. When you reset, GPS will re-initialize, so it takes a certain amount of time to search for signals.