CubeCell AB02 GPIO5

I have been trying to test the CubeCell on a Battery Monitor. I have GPIO5 set up as a trigger so at various points in the code I can trigger a high or a low in order to log the power usage and get an idea what is being used during the various cycles.

On starup I have
pinMode(GPIO6, OUTPUT);
digitalWrite(GPIO6, LOW);

that works and I have confirmed that the trigger on the scope is low, Then at the start of the chosen routine I do a digitalWrite(GPIO6, HIGH);
The scope is set to start recording on the rising edge.

At the end of the routine I do a
digitalWrite(GPIO6, LOW);

This should trigger the scope to stop recording however GPIO6 is not going low.

I also tried this on GPIO5 and had the same issue.

it seems that once the GPIO goes high its it will not go low again.

Weirdly if i do put the scope on that pin I see it attempt to drop but quicly returns to 3.3v as if its being pulled back up.

Also tried GPIO14, and have the same issue.

You can try to measure the pin voltage with a multimeter, and pay attention to avoid other interference.

I sure did, Both on the scope and the multimeter it was low on start up, then the pin was set to high and it jumped to 3.3v (or there abouts) then when digitalWrite(GPIOX, LOW); was called the pin stayed at 3.3v