Cube Cell HTCC-AB01 failure

Hi all. I have a HTCC-AB01 powered by USB cable to my desktop. I am using it to receive LoRa data from a SX1276 module with a Temp & Hum sensor. It worked fine for 2 months but since last week it stopped. The device is not more recognized by my desktop even in Linux Mint 20 and Windows 10. I have measured the Vdd, Vin voltages, and are ok. I suppose the USB to UART bridge might be with a failure. Anyone with the same problem? Any suggest procedure?

When I connected to the USB port the LED located near the USB connector remains ON. There is no identification in the device management, its not recognized in the Arduino IDE.

I think the USB on the development board may be broken

I want to continue using my LoRa Module so I will remove the CP2102 Chip in order to use an external FTDI board. Could you please share with me the Schematic Diagram of the HTCC-AB01 to better understand the Circuit?


please refer this:

Thank you Sr. It worked.

I removed the USB to UART bridge CP2102 with a hot air gun. Then I plug an FTDI external board to my CubeCell Board with the Rx to Tx and Rx to Tx serial pins, also CTS, DTR to Ground.

Before plug your board, hold USR key and plug usb back in. Now you can upload your code.