Heltec Wifi Lora 32 (V3) Board unrecognition

Hi,

I tried to run Heltec Wifi Lora 32 (V3) with seleceted board named ESP32S3 Dev Module and it could run only simple codes like Serial.begin. Then i tried to run inbuild display but it didn’t work so i changed board to Heltec Wifi LoRa 32 and it didn’t want to upload and returned this:

A fatal error occurred: Failed to connect to ESP32: No serial data received.
For troubleshooting steps visit: https://docs.espressif.com/projects/esptool/en/latest/troubleshooting.html
Failed uploading: uploading error: exit status 2

@garry1644,

First up, you need to have installed the latest Heltec support software (refer to this post), then you need to select the board identified as:

WiFi LoRa 32(V3) / Wireless shell(V3) / Wireless stick lite (V3)

If you can’t see this board anywhere in the board list, you probably don’t have the correct support software installed. Previous ESP32 code (whether it’s from Heltec or anyone else, I believe) will not run on the new ESP32-S3 processor.

There are now several recent posts discussing issues with getting connected to the new V3 boards, so check them out and see how you go following the recommendations provided therein.

If you’re still having trouble, include a description of your development environment (Arduino IDE or whatever, and on what OS platform) in your next post.

And if you succeed, it would be helpful if you could post a reply letting everyone know what your problem ultimately was and how you corrected it.

I did what you said and it loads now, thank you for that. But i have still problems with witing on OLED. I’v tried few of libreries like Adafruit_SSD1306 and 8x8lib and sadly it did nothing.

So now I tried to go into heltec examples and run some Factory_Test and OLED finally works! Thank you for helping me.

And I was literally just writing to suggest that as your reply came in! Pleased to hear it’s all OK now.

Has anyone had any luck getting the V3 boards to work with the PlatformIO tools?
This still seems to be missing.

I’m interested in getting V3 boards to work with PlatformIO also. Does anyone have an update?