Can't compile examples with cubcecell 1.0.0

Hi fellas,

something went wrong with the update from 0.0.5 to 1.0.0

i’ve tried to compile my sketch with the new version and it failed with the message in the setup scope “Vext was not declared in this scope”

Also failed with the example sketch “LoRaSenderRead_Battery” with the message “VBAT_ADC_CTL was not declared in this scope”.

do i missed something?

After downgrade to version 0.0.5 it works again.

Try to delete the old version and install the new one aftrrwards

Hello wasn,

thanks for the reply.
I’ve already deleted the whole cubecell package and reinstall it over the arduino board manager.
Also tried an another notebook. unfortunately all ends up with the same result as before.

dump question but have you selected the right board?
Can you post four source code and a screenshot of your board settings in the Arduino IDE?

I just deleted the source package folder again and reinstalled the cubecell.
I’m using the cubecell module with the asr6501.

In this case the sketch is the example “LoRaSender_ReadBattery”

The module does not have vext control or vbat measure build in.
This is only out of my memory.
I am right now on the move.

1 Like

Hi @vino2300

@wasn‘s answer is correct, you need to make a macro definition for the pin.

You are right. works fine now! :slight_smile:

Thanks @wasn @Supporter